libphp5.so error

libphp5.so is not generated when installing PHP:
httpd: Syntax error on line 53 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/modules/libphp5.so into server: /usr/local/apache/modules/libphp5.so: cannot open shared object file: No such file or directory

This could be from the version difference of libtool. Copying libtool from Apache folder to PHP, then make clean -> make -> make install would fixe the problem.

For example, if Apache is installed under /usr/local/apache, and PHP folder is php-5.3.8, run cp /usr/local/apache/build/libtool php-5.3.8/

Leave a Comment

Before leaving a comment, please ensure you have read and understand my comments policy and my privacy policy. Any comment that does not abide by the comment policy will be deleted immediately.

Related Posts